Overview
Within the ShadowProtect management console GUI, a new agent/node connection in the Management View fails with the following message:
The RPC server is unavailable
Common Cause
A firewall is blocking traffic from the ShadowProtectSvc.exe process on the BDR (or server running the management console GUI) to to the new agent/node machine.
Resolution
The recommended solution is to add an exception in the firewall on the machine (agent) being backed up.
Steps to add the exception:
- In your Start Menu search box enter "wf.msc". This will open the “Windows Firewall with Advanced Security” settings.
- On the tree in the left panel, right click on "inbound rules" and select "New Rule...".
- On the rule type, choose the "Program" radio button and click "Next...".
- On the Program Page, click the "Browse..." button, navigate to C:\Program Files (x86)\StorageCraft\ShadowProtect", select "ShadowProtectSvc.exe". Click OK, and then Next
- On the Action Page, choose the "Allow the connection" radio button (default setting). Click Next.
- On the Profile Page, check all of the check boxes. (default settings)
- On the Name Page, enter "ShadowProtect Service" in the name box.
- Click Finish to close the wizard.
- Return to management view on the target machine and attempt to connect.
NOTE: It may also be necessary to enable existing DCOM-in rules. This can be done in the inbound rules pane, of the Windows Firewall Management Console on the source (agent), ensure the rule(s) named "Windows Management Instrumentation (DCOM-In)" are enabled (green checkmark).
Further information regarding this error can be found on the StorageCraft Website at: http://www.storagecraft.com/support/kb/article/95